Digiprog 3 Reviews Feedback cars that work & cannot work

Here OBD2TOOL collect newest Digiprog III Digiprog 3 real customers feedback what can work and not work vehicle models.Hope it helps!

Digiprog-3

Digiprog Cars that work:

W204 (C) EZS – DIAG ok , 2 min
W204 (C) – TACHO – DIAG ok, 2 min
W204 (C) – ASSYST – DIAG ok, 15 min
FIAT BRAVA 2008 OBD work
GOLF 5 2008 kombiistrument 3HL , OBD -OK 1min
GOLF 5 2008 ECU DIAG R4 1,9L EDC 000SG OBD-ok 10min
VW Sharan 2008 dash OBD –ok
EDC 16 U31 via OBD not work( can`t write new Mileage Correction)
PASSAT 2011 Colour Dash OBD – OK !!! 5 min
Golf 5 2006 odo and ecu OK
Fiat bravo 2009 odo OK
Fiat 500 new odo ok
caddy 2011 work without an problem.

Same as suppliers say :
BMW 1er / E81/E82/E87/E88 CAS3 Diagnostic OBD
BMW 3er / E90/E93 CAS3 Diagnostic OBD
BMW 5er / 60/E61 CAS3 Diagnostic OBD
BMW 6er / E63/E64 CAS3 Diagnostic OBD
BMW X5er / E70 CAS3 Diagnostic OBD
BMW X6er / E71 CAS3 Diagnostic OBD

Skoda Octavia 1.9 TDI PD 08.2008 year
Dash~1min OK
DSG ~30sec OK
ECU~ 5min OK

VW Touran 2007 1.9 TDI PD
Dash~1min OK
ECU~ 5min OK

LANCIA PHEDRA 2002 (CITROEN C8, P 807)
BSI HC912 OK
DASH 95020 OK

laguna 2005- 9s12 ok

BMW EWS 3 (OD46J) with ST35 , works perfekt!!

Audi A4 RB8 correction OBD ok (1min)
Tried ECU(like Passat B6) read km good, but after 5 minutes of reading-writing got same km.
Yes correct. Now read and inserted new correct km. . On golf 5 edc16 i do so and all ok

Focus 2009 today, went OK..

Golf 5 2007 ODO AND ECU EDC16 ok

A4 8K 2008- by obd.Yep! Ok!
Hello
is there anyone who tried A4 8K 2008- by obd.
for me never work with that car
funny thing i do all with the vag k + can ( blue toy )

Polo 4 magneti ok
Passat b5.5 ok
Audi rb4 ok
Micra 2004 ok solder points

A class 2001 not work(shows new km for a second and returns old)
did you use the right version in software A Class
A class w168 works but only with engine running

Peugeot 306 by dashplug working good

w211 2006 years by obd it work good
no need to remove ezs and dash; only by obd
2 munite
Only flash dashboard old km still in EZS and many other module on W211 . Neither device can not do km in EZS on OBD

(w203,w211) Mororola 9s12 and 912
i tried the w203 2001 years no connection but the w211 work good i use the programm tacho diag by obd the digi reads

actuel mileage correct ,i put the new mileage it work fine no need to remove any fuse and the programm fehlerspeicher work good also Audi Q7 2007 works ok 30sec. (I accidently used touareg 2004 up menu in digi vigi and it recognized old km and changed no problem)
Read all posts and you will find the answer,
I tried it on a A3 M73 dash (first make backup with upa) than i tried with Digi Prog.
As i could remember i reads good milleage but does not change the milleage, removed battery for a while and milleage stayed the same.
Finally changed milleage with good old TU by cluster plug.

Ecu 3.0 tdi wrote no connection. Dp3 cant do it either.
Focus 2010 10sec ok

Passat 2009 – 1min OK

Passat 2012
Fiesta 2011
Fiesta 2008
Works OK
is the 2010 fiesta just the same

***353;koda 2007 tacho diag ok 1 min
ecu diag ok 5 min

VW Golf MK5 2.0 TDI 140cv DSG BKD Engine

Dash kms : OK
DSG kms: OK
ECU Diag: Unknown version, not read
Service: OK

Peugeot 308 2011 odo 95080 and BSI 95128ok

VW Polo 2012 only obd ok

Yamaha R1 2008 95lc56 work ok.

citroen c2 2004
digiprog 3,plug1
tacho siemens c46
bsi siemens 95160
read ok
write ok
p.s.
psa bsi tool not respond tacho and bsi

audi A4 2010 ok.

with Visteon work good

Golf6 m.m 2011 done by obd in 5 minutes,work

Skoda Fabia 2007 1.9 Dash and Ecu by obd work ok

Digiprog 3 clone in mercedes w204. Thanks, working 100%
Dash diag is for doing dash only when using CAN blocker

Fiat 500 obd work ok.
Audi A3 2010 obd Work ok.

Can someone please post the Digiprog working CAS lead schematic as the one ive got looks like its been totally

bodged as expected. I allready have the schematic for direct cas plug in pins, but im looking for the “Dash plug

connector schematic” if that makes any sense.
Also can someone please confirm if they have managed to do a facelift 2007 BMW E65 CAS yet with Digiprog clone ???
Thanks in advance
black pin 13
white pin 12
orange pin 9
red pin 10
on the dash plug check tracks
this picture shows you track repairs
Black and white tracks just need repair
Red and orange tracks discard and use wire to put to the right pins
also
Audi Q5 2011 Takes 30 min Diag OK

Audi a6 2005 Obd work ok

2007/2008 polo with c86 crypto through diag, first i took out dash made backup with upa and then put back and

programmed all ok.
i also did a 2008 polo with 9s12 with soldering back on board all ok.
so i think you can try but make a backup first.

skoda octavia 2012 diag ,ok,5 min!! 4.82 version ,octavia 2008>
after write km,must connect diagnosic and erase faults airbag
regards

VW Bora 2008 micronas + 24c32 via OBD OK!
VW Jetta 2012 Nec + 24c64 via OBD OK!

Golf5 Dash Visteon 95160 less than a minute OK
Golf5 ECU EDC16 – 6~8 minutes OK

mercedes a-class A160 , 2000year ,obd diag ok ,1 min!
meni w168,diag not read old km, write new,tacho restart!
service not work!!

Caddy 2012 ok, polo 2012 ok
If it was polo johnson controls screen goes black

Audi TT `00 M73 diag – read old ok and write new ok

Quote Originally Posted by 88diablo View Post
Land Rover Freelander2 2008 -Dash and BCU OK
Ive beed tried one but bad calculation on BCU.
dash ok.
The one I did was 57 plate 2008 model. It was BCU diagram 1 in the PDF. I took the 2 boards apart first and read

with UPA to be safe but then put back together and did with Digi in circuit. Did all the fuses and drive 2km

procedure and all was fine.
Full marks for energy………..and with eyes like that it must be difficult to drive 2km
its amazing what a couple of hundred quid can get you.

touareg 7L 2009 ok

Dodge Caliber 2008. HC12 with plug 48 OK 2 min. Removing cluster not fun.

Scoda Fabia 08 dash k-line 5J0 crypt , obd2 read old-? , write new km OK !!!

edc15 works only direct to chip, not obd. use simple kkl cable for them
edc16 works obd with digiprog

Scoda Octavia 2011 NEC 24c32 5min OBD fine

and T5 07 dash (full MFA) obd write-Ok
ECU EDC16 read and write- 7min ALL FINE

did corsa c 05 without problems, only you have to hold trip reset button while programming, and after that

disconnect battery for a few seconds

JEEP COMPAS OBD FINE

corsac obd OK

ford fokus 2002,read old km—-not write new km

opel insignia obd ——-not comunicate do via chip

2004 VW TOUAREG OBD OK
2006 AUDI A4 OBD OK ( M73) DIDN’T READ

Tried to do e71 X6 but no joy. Read correct miles and went through procedure and asked to reinsert dash etc but old

mileage return in dash when done.you mean cas try obd dont work?
Yes I did dash then tried to do cas with obd but no joy.

Honda cr-v 2007 93c76 plug 1, read old km ,write ok

Q7 2007-2008 r/w ok
A4 2007 r/w ok (and exact km )
c1 2008 r/w ok
touran 2005 r/w ok

Skoda Fabia VDO 6Y0 920 883M B41, 93c86 by OBD OK, DIDN’T READ

Golf 6 2011 read/write ok in 5min

Fabia read ?????? but write ok ( 2002y)
Focus 2003 24c16 by eeprom clip read/writes OK.

yes, dont read the original, but can write new km, skoda fabia 2004, 93c86 inside, do it by OBD

opel Meriva 2004,obd ok 5 min!!
not read old km write new,but mast hold trip Yes same procedure for corsa c

Citroen xsara 2004 dash sagem 93c66, bsi valeo 95040,
by eeprom clip
read/write km OK

Astra G ’99 with TRW dash.
Dash with 24C02 eeprom. Read/Write OK with eeprom clips

Originally Posted by norbisko View Post
2006 Ford fusion obd- not work
2006 VW Jettta – dash read wrong mileage (34,xxx miles )
ecu – unknown version
dsg- read wrong mileage ( 22,xxx miles)
Btw for Plug 1 am I suppose to have a eeprom clip ? I just have the board that says 01/04.
yes eeprom clip or use the board

Audi s5 2009 reada write ok about 30 min

Porsche Cayenne 2005 Read & Write – OK

A6 3.0 tdi 2006 dash OK
Edc 16 Not OK.

Audi A4 2011 obd OK
Vw Caddy 2007 OBD OK
Opel Corsa 2004 OBD OK
Opel Meriva 2007 OBD OK

Mk4 golf obd ok
Mk5 golf obd ok
2010 passat ok
2006 a3 ok
2009 a4 ok

Passat B5 year2000 vdo,no connection.
But under golf menu are OK.

did 2008 transporter,
old mileage show ????,enter new OK
try ecu,read OK,write OK(take 10min) but still old mileage.
later done ecu with bluevag in couple minutes.

stilo 03 with cable 51 OK,
CAS2 with direct cas plug connection OK
CAS3 read crazy mileage something like 23143236,did not try to change(try just for play).

Volvo v70 2011 read write ok and mileage didn’t jump back!

Golf 5 obd ok
octavia 2007 obd ok
vw lupo obd ok
astra 2000 obd ok

2008 superB obd ok
2006 Suzuki swift eeprom ok

passat CC 2009 dash OBD ok
DSG read wrong kilometer do somebody have solution for this use vcds for dsg you can reset is with vcds to 0, i

think digiprog does the same. procedure is explained here on forum i try to DSG vw passat b6,yes read wrong km but

put in 0000000
and read again 0000000!Can confirm that digi put 0km to the DSG (in Octavia at least)Just put 0 in DSG

DSG km reset with VCDS

Golf 6 2011 MM5 obd ok

kienzle 1324 with adapter 47 on solder points,went fine and quickly.

ford ranger 68hc05 ok

punto 2004 obd ok
doblo 2005 obd ok

Golf 5 2006 1,9 tdi –obd OK
Focus 2007 1,8 TDCI –obd OK
Passat 2002 1,8 20v –obd OK
Mercedes A 2004 1,7 CDI — obd OK

cables and adapters used to digipro3 tacho 2008 clone would need to know if the cable 42 of digipro is the same

tacho 2008 908
im confused…

I can confirm that EDC16 work.

I did
VW Golf 5 => ok
Audi A6 => ok but with Golf 5 menu. When i tryed with in Audi A6 menu, it didnt worked. So i readed it with Golf 5

menu, KM that was read was ok, so i changed it it worked !!!

Volvo XC90 2011 MC9s12DG128 ok

Audi A4 09 diag, 2011
Ford Focus diag,
Peugeot E7 BSI and dash,
Fiat Doblo diag,
Honda Accord,
Peugeot 407 06,
Peugeot 406 bsi and dash,
ford Transit
Just done a merc 204 and 212 Diagnostic mileage and assyst
A4 I did one yesterday
merc 204 212 tried and tested
Audi A3 2006 Diag
Mercedes 212 Diag
Mercedes 204 Diag
Mercedes 204 assyst Diag
Mercedes Vito MM Diag
Ford Focus 2008 to 2011 Diag
Ford Fiesta 2008 up Diag
Ford Mondeo 2008 Diag
Fiat Doblo Diag
Nissan Navara 9S12
Peugeot 307 912 BSI
Peogeot 307 95160 BSI
Old Toyota Avensis Diag back of cluster
Seat Leon 2006 Diag
Toyota Dyna contact points using Hiace
Volvo V70 Diag
Volvo V70 error clear
focus 2011 diag
Porsch CAYENNE
2002-2010 (diag and 24c08)
2010-up -only 95640 eeprom
New Volvo goes by OBD tried and tested
2008 up I did V70 the other day and error clear works
Even on 211 you cant make assyst by OBD
Astra-j (2009) works OK via OBD
VW Passat 2007 works OK via OBD
Astra-H works OK via CHIP
Audi A8 2007 works OK via OBD
Ford C-Max and S-Max work OK via OBD
Ford Fiesta & Focus works OK via MCU, not Dash Connector ?!?!
Golf 3 & Golf 4 works OK via dash connector and via OBD
Reading 93Cxx, 24Cxx, 95xxx, 912, 9s12 works OK.
Vw T5 DASH -2009 OBD OK
EDC16 T5 – 2009 OBD OK
VW T5 DASH 2005 OBD OK
EDC T5 -2005 OBD OK
CADDY 2009 -OBD OK
bMW 5 – BY DASH PLUG 1998 OK
SKODA SUPERB- 2007 OBD OK
BMW CAS 2 (2004) BY CAS PLUG OK
Golf 6 2009
renault megane 3 only dash ,abs 95160 does not work
Megan 3 ABS, work only with ESP unit ,without ESP not work
Golf 5 2005 2006 2007
Seat leon 2007
peugeot 207 95128 but you must select citroen C3 menu
Skoda fabia 2001
clio 3 2009
c4 2006
i try ford smax work fine i think with fords work fine
Volvo S 80 from 2009 done in 5 minutes,
vw eos 2007 in menu -2009 (1F) dignostic
read and change km in tacho and DSG
t5 by obd worck ok,dash and edc
citroen c2 dash & bsi ok
galaxy 04 plate ok
mondeo 04 ok
golf mk 5 06 ok
Golf 5,2008 ok,
golf 6 2011 ok,
ford focus 2007 ok,
t5 ok,edc 16 ok,
seat leon 2007 ok
BMW E46 by 20 pin DLC work ok year 2000
Insignia work by Eprom direct,OBD get acces denied
Mercedes 2008 by OBD work ,dash only!
Nissan quascai 2008 by eprom direct working
tested on 211 2008 work with flashing option(block syncro with EZS in dash flash)
audi a4 ,2.7 benz, 1999 year!
93lc66 , b5-dash 8d0 vdo with BC!!!!!
audi a4 1994-2001
audi11/97-
diagnostic connect,not read old km write new km ok
2011 ford focus like a dream obd2
golf4 19tdi 2000year
Rb4 audi a4 make today ,worck like a charm,
seat ibiza 2004 the same worck ok
skoda octavia with nec inside work ok by obd
T4 2006 obd ok (meni:vw T4 98-/diagnostic connect,not read old km write new km ok)
jumper 2008 obd ok read old km write ok
Peugeot 406 VDO Dash done by cluster conector…ok
Focus 2001 Done with cluster connector ………….ok
Audi A3 ,2000 year, M73 works OK via OBD
mb w204 2011 obd2 work ok take 2 min cleare error work ok
Passat 2012
Fiesta 2011
Fiesta 2008
tested on audi A8 4E-work ok;
ford focus 2010-OK ;
tuareg RB8 dash-ok and EDC16-OK
2009 Audi R8 done OK
2009 Insignia done OK
Chrysler 300C
2008 Mondeo Colour screen
did mb w204 2010 w212 2011 2 min joob done. work very good.
insignia 2010 by obd 1min job
audi a4 2008 …. by obd 30min job
audi a6 2004…. not from first try but ok (q7 the same )
audi a3 2003…. obd 1min job
mb ml 1999 obd ok
a4 1996 vdo obd ok
volvo xc 70 2008… obd ok
focus 2008 obd ok
sharan ….2001 with and without bord cpu obd ok
mercedes w 204 2009 year
W204 (C) ***8211; EZS – DIAG ok , 2 min
W204 (C) – TACHO – DIAG ok, 2 min
W204 (C) – ASSYST – DIAG ok, 15 min
Tested ok on vw polo 2007 crypto
punto 2004 old shape
seat cordoba 2003 old shape
scenic 2004 johnson control with c56
e60 dash with 35080 eep all ok.
mazda bt50 2009 ok
ford escape 2008 OBD ok
vw golf 6 ,2011 , VDO tacho obd 2 min !!ok!!
for the audi a4 2008 demand 1 min for reading and 30min for writing
a4 2008 30min job work ok by obd
I did a Audi A8 with Digiprog clone by obd the other day… worked perfect… it was 2008.
Vw polo 6r 2011 obd OK
VW lupo obd OK
Vw passat B6 -2008 obd OK 1min
Tested on VW Passat EDC16, working
Golf4 vdo ok edc 15 not work
tested on a 2001 corsa and all ok
try it the golf 5 ecu works diag
I read and write to obd VW T5 2007-8 year tacho and edc16

Digiprog 3 Tool Cars that not work:

You made 221 without can filter?
off course with can filter

mercedes w221 2007 cluster ok assyst ok
mercedes w164 2006 cluter ok assyst ok
astra 2010 cluster ok
bmw e60 cas by cluster plug km changed in wrong adress and red dot on cluster remain !!!
corsa c ecu eeprom direct not work
space star 2002 eeprom pointers dont work after !!!
ford connect 2002 with 912 with cable 48/2 cluster dead mcu not readable even with etl !!!
What you mean bmw e60 cluster plug?
You mean you did cas try dash plug
Cable 62 and you have dot.
Dot will desapere after 19 km.

with dp3 cas 3+ work try obd with out any problem.
cas2 with dp3 dont work i try like 11 cars no luck
e65 with dp3 obd dont work.
Freelander 2 2008 wrong calculation
the only one not on is Audi A1
jeep cherokie 2004 908as60 plug 42 not work
VW polo 2005 dash VDO not work
Audi A6 2003 dash not work
Audi A6 2005 dash work( test only if is read i not change it)
VW T5 EDC16 read km ok by OBD,write … but km still not change,i removed ECU and mod eeprom
vw lupo 2002 with rb 4 dash not ok
get message “unknown version rb4”
try old 912 bsi 307 with this tool and now bsi dead
fiat punto 2000 read good milleage when programming is finished it says verify new milleage but milleage still the

same
Tested on Audi A4 EDC16, not working.
Ibiza 2007 dash MM with 912h256 inside, can’t do by OBD
MERCEDES A-CLAS – 2000 OBD NOT OK

Tested on W212 ecu year 2010 commender not read
W211 ZGW not work
dash eeprom 95020 citroen berlingo 2012 dont work “unknown version
FIAT PUNTO 2008 OBD not work
Mercedes CLK W209 from 2003 did not work by obd.
Evo no
C-Max 2005 with 590k km both digiprog and carpog 4.01 sing – “Unknown version”.

Focus (old shape) not good just checked cable and the massa is on the wrong pin after that i did not check anymore.

2004 Touran 1.9 tdi ecu km… not working, dash is ok. On ecu reads Km ok after writing new km value still old km

displayed
touran 2004 is edc16, do it manually

A6 ,4G, 2011 obd ,no success
read old km not corect

MB CLC 2009 dash plug don’t work …

Ford Fiesta 2002 via obd not work

Ford F150 2002 with HC11… N O N E S !!!! wasted time… Not working… After try connection show E R R O R !!!
F150 2002 i have do 2 weeks ago with digiprogclone and works fine. have you make wrong job

Opel Astra 2.0 DTI from 2001 with VDO, and when I try to connect with OBD cable, screen shows “unknown version

vw polo 2012 didnt work
i have make Polo 5.2012 and work

Chev Kalos / Aveo HC08 does not work on “Clone”
HC08 not work on any dash ….
tested on many
Hi guys 908 work fine on mine done many I guess you just need to know how to work it !!! Take note most of the leads

that come with it are either poor quality or wired wrong

not work with golf 6 2011 Nec 24c64

Today do Golf6 2011 Dash MM read old value ok and write ok, But dash now say: Error and not show value
Try different value and double check which version of dash is
Yes, this car work whitout dash

Q5 2012 don’t work
EWS3 don’t work

Ford Escape 2007, no work obd2, cable 16
error unknown dashboard

corsac obd OK

ford fokus 2002,read old km—-not write new km
opel insignia obd ——-not comunicate
Cable ford focus not ok.
Check with scheme or compare with other programmer.

2006 Ford fusion obd- not work
2006 VW Jettta – dash read wrong mileage (34,xxx miles )
ecu – unknown version
dsg- read wrong mileage ( 22,xxx miles)

Btw for Plug 1 am I suppose to have a eeprom clip ? I just have the board that says 01/04.

Mercedes c200 cable 8/9 no works
cas plug 35pin(black) to digi 10pin
cas plug 34pin(green-red) to digi 25pin
cas plug 26(yellow) to digi 9pin
cas plug 12(braun-black) to digi 13pin

for 48/2 i think this:
brown pin 13 gnd
white pin 7 +5v
green pin 17 Reset
yellow pin 18 BCKND
work on 307bsi,no work on rexton dash(did with carprog).more not tested.

I have read from various users that most EDC15-16 not working… Is that right? I only got one to try on…Touran

2005 EDC16 and did not work… Somebody that is using his one more often, what are your experiences? Thanks.

Have you cleared DTCs with Digiprog ?
customer called me and ask me to help him.
some guy have change S80 with clone didgiprog for him
and after he had this problem. the guy tryed to clear error but problem remain.then i tryed with ori digiprog and

DSP 3 and smok and smelecom and diag tool to clear error but no joy.
after spend couple days trying this and that i have extract the flash repair it and then all problem was gone.
on this forum also other members had the same problem with volvo’s using clone digiprog.it damage the flash!

hi
jeep cherokie 2004 908as60 plug 42 not work
regards
dont work at all, I try with two models of boards

Megan 3 ABS, work only with ESP unit ,without ESP not work via epprom

How to fix Citroen Picasso 2009 BSI flash problem using DP3

Car information:

Citroën Picasso 2009 with BSI and 95128 eeprom / Johnson Controls.

Mileage Tool to use:

Digiprog 3 (DP3)

Spend $179

http://www.obd2tool.com/goods-1754-Hotest+Digiprog+III+Digiprog+3+Odometer+Programmer+with+Full+Software.html

best-quality-yanhua-v494-digiprog3-1

Error description:

DigiProg 3 has done writing the new km value by “flashing” by OBDII “reading, verifying, writing” but only until 99 %.

Now car is “dead”, no functions anymore.

Need to tell also that i forgot to put extra battery charger, so this was happen when voltage dropped and now car is “dead”

Re-write with DP3 is possible apparently, recognize BSI number (but NOT the VIN) and does automatically pick-up the saved

“flash-file” and will try to recover, BUT DP3 don’t flash anymore when arrived @ 99%….

EEprom data looks okay

Put all FF in eeprom also don’t wake up the car.

 

Reference number on label:

PSA = 96 640 590 8002

V 05.01

281201930C

N805243015

boot 28120836-4

hard 28119248-3 C

BSI 04 EV K04 – 00 020309

bsi

Finally solved after all I managed to “repair” it as follow:

Please firstly look at the flash dump “BSI_JC_FLASH_M00″

https://mega.co.nz/#%21RdZAAKbA%2116LeW9udnGH_2cw-o9jqx96fdjSpb3QuELZKo2JaOs4

full of area’s with “00″, so its corrupted in my opinion.

Each time DP3 will try to restore, also as commanded in the log-file, the original flash.
But for some reason DP3 take all time the “BSI_JC_FLASH_M00” and stops at 99%.

In the MCC card/storage there is some other 992 kbyte flash with name “BSI_JC_FLASH_01″ which is the +/- SAME as “JCI_BSI_678A”

“JCI_BSI_678A”: https://mega.co.nz/#!McRTjJgL!fp94IF-fvasqpGlQYAH8h16pM9wIZ6PqUeRcj0Nyv7U

This flash is the real original flash, and the “…M00″ is the modified flash.

Now the trick is : change the name from the “01″ flash into “M00″ and the “M00″ into “01″.
Then DP3 will AGAIN try restore the flash with of course “M00″, but this time the content is the good one because i “misleaded” DP3 by changing file-names

And indeed, this time until 100%, car start and you only need to re-do the whole procedure “read, verify, write” BUT THIS TIME WITH AN EXTRA BATTERY CHARGER .

Hope this will help some members with the same problem.